Помогите перевести T2.6 (High Five) - OverWorld на 8-ю яву

sergebaz

Знающий
Местный
Сообщения
258
Розыгрыши
0
Реакции
37
Баллы
386
хочу переделать исходники T2.6 (High Five) - OverWorld на 8-ю яву, данные сурсы будут полезны при создании любого проекта как основа. Итак опыта в этом деле мало, сильно не пинайте..., итак в файле build.xml поменял 1.6 яву на 1.8, открыв сурс в еклипсе вижу ошибки, в частности Fighter.java и др, если скомпилировать исходники много вылетет варнингов и при запуске гс вылетает ошибка скриптов помогите с данной проблемой...
 

sQula

Интересующийся
VIP
Сообщения
300
Розыгрыши
0
Реакции
137
Баллы
216
а смысл?) если не использовать фишки 8 явы, какой смысл переводить...
 

DarkMEn

Участник
Пользователь
Сообщения
40
Розыгрыши
0
Реакции
2
Баллы
50
хочу переделать исходники T2.6 (High Five) - OverWorld на 8-ю яву, данные сурсы будут полезны при создании любого проекта как основа. Итак опыта в этом деле мало, сильно не пинайте..., итак в файле build.xml поменял 1.6 яву на 1.8, открыв сурс в еклипсе вижу ошибки, в частности Fighter.java и др, если скомпилировать исходники много вылетет варнингов и при запуске гс вылетает ошибка скриптов помогите с данной проблемой...
Fighter.java Там вроде подстава есть на зг по ищите тема была как решить проблему там мелочная она.

И лог скинь
 
Последнее редактирование модератором:

sergebaz

Знающий
Местный
Сообщения
258
Розыгрыши
0
Реакции
37
Баллы
386
В сборке после компиляции отсутствует scripts.jar, если есть желающие помочь- добро пожаловать, готов поделиться рублями...
 

merdox

Интересующийся
Местный
Сообщения
103
Розыгрыши
0
Реакции
32
Баллы
279
хочу переделать исходники T2.6 (High Five) - OverWorld на 8-ю яву, данные сурсы будут полезны при создании любого проекта как основа. Итак опыта в этом деле мало, сильно не пинайте..., итак в файле build.xml поменял 1.6 яву на 1.8, открыв сурс в еклипсе вижу ошибки, в частности Fighter.java и др, если скомпилировать исходники много вылетет варнингов и при запуске гс вылетает ошибка скриптов помогите с данной проблемой...
Уж лучше тогда LostWorld взять) да и смысла нету переводить на java 8, только из-за того, чтобы подгружать под 8 java.
 

Daan Raven

Свой человек
Проверенный
Сообщения
773
Розыгрыши
0
Реакции
339
Баллы
469
Есть смысл, но для тех, кто подобные темы не создает.
 

ArtToKill

Местный житель
Партнер
Сообщения
1.678
Розыгрыши
2
Реакции
1.565
Баллы
1.150
хочу переделать исходники T2.6 (High Five) - OverWorld на 8-ю яву, данные сурсы будут полезны при создании любого проекта как основа. Итак опыта в этом деле мало, сильно не пинайте..., итак в файле build.xml поменял 1.6 яву на 1.8, открыв сурс в еклипсе вижу ошибки, в частности Fighter.java и др, если скомпилировать исходники много вылетет варнингов и при запуске гс вылетает ошибка скриптов помогите с данной проблемой...
а тебе просто нужно версию компилятора изменить?или еще избавиться от джарок?
 

sergebaz

Знающий
Местный
Сообщения
258
Розыгрыши
0
Реакции
37
Баллы
386
Мне нужно все по максимум 8-ю яву...
 

ArtToKill

Местный житель
Партнер
Сообщения
1.678
Розыгрыши
2
Реакции
1.565
Баллы
1.150

sergebaz

Знающий
Местный
Сообщения
258
Розыгрыши
0
Реакции
37
Баллы
386
та же ошибка со scripts...
 

Falkland

Пляшущий с бубном
Местный
Сообщения
140
Розыгрыши
0
Реакции
55
Баллы
178
Если переводить "просто так, чтобы было", почему не сразу на 10?
А вообще по крайней мере в лосте весь перевод ограничивается только заменой ecj.
 

GoGLiKK

Бог Cмерти
Легенда
Сообщения
1.108
Розыгрыши
0
Реакции
1.033
Баллы
1.105
попробуй выпилить ecj

не бейте
 
Последнее редактирование:

Daan Raven

Свой человек
Проверенный
Сообщения
773
Розыгрыши
0
Реакции
339
Баллы
469
Если переводить "просто так, чтобы было", почему не сразу на 10?
А вообще по крайней мере в лосте весь перевод ограничивается только заменой ecj.
Тогда уж сразу на 11, раз такое дело.
 

ArtToKill

Местный житель
Партнер
Сообщения
1.678
Розыгрыши
2
Реакции
1.565
Баллы
1.150
Я бы не советовал прыгать на промежуточные версии явы)
 
Сверху Снизу